Floating Supply Outputs

9 posts / 0 new
I am Using TOP245YN on universal input to get 5V@1A(Floating),15V@1A,12V@1A. With No load on 5V and 15V is Loaded(200mA),its output goes low. I have attached my design. I think i should adjust feedback gains. 5V@1A is used for Logic supply for my design 15V@1A is used for Mosfet Drivers to drive 500V MOSFETS I Want 5V and 15V supply to have no common return, so as to isolate my high voltage power and logic supplies. If any other ideas suggest me.
첨부 파일Size
Floating Supply.pdf21.63 KB

What you have is the classic cross-regulation problem. By how much is the 15 V output dropping? What kind of tolerance are you expecting on this output? If you want to drive a MOSFET you probably need only 10 to 12 V
I can suggest a couple of things you can try
1) In the transformer construction place the 15 V winding immediately next to the 5 V winding. This improves coupling between the 5 and 15 V windings
2) Try to minimize the secondary trace inductances for this 15 V output (Place its diode as close to the transformer bobbin pin as possible)

Let me know what voltage you are seeing on 15 V when loaded...

With 15Volts Loaded at 200mA i get output voltage dropped to 7.5V and if 5V output is loaded at 200mA while 15Volts is open, 15V output gets increased to 30V. I want 15V@1A with 10% Tolerance.

Can you post your transformer winding order and primary and leakage inductance values. Also post what your layout looks like. Generally these problems occur if there is loose coupling between the regulated output (5 V) and the unregulated output (15 V). This may also happen if the loop area for the 15 V output is large.

I have tried three winding techniques.. (1)Normal winding = (Primary -> Bias -> 12V -> 15V -> 5V) (2)Primary Side Feedback = (Primary -> 12V -> 15V -> 5V -> Bias) (3)Split Primary = (Primary1 -> 12V -> 15V -> 5V -> Bias -> Primary2) With all these I get same problem. Primary Leakage Inductance = 15uH
Still I am not having any solution. Please help me out to design my floating supply.

attaching a few things about your layout. The loop areas on the secondaries need to be small. Length of traces which carry switching currents and voltages should be small. The location of feedback resistors should be moved to the right near the output. This will make room to move switching components closer together.
See some of the multiple output layouts from PI (RDR-115)
http://www.powerint.com/sites/default/files/PDFFiles/rdr115.pdf

I have Modified the Layout. Please check and suggest if any routing issues.
Also I have Noticed that When 5V is Loaded(400mA) and all other outputs are Lightly Loaded(10mA) Bias Winding voltage goes to 14V from 12V. When 15V is loaded(400mA) and 5V is at light Load(10mA), Bias Winding voltage drops to 10V. I don't know whether it is ok or there is fault that creating the problem.