Flicker & poor current accuracy in LNK406

4 posts / 0 new

I am getting poor current regulation in  non-dimming LNK406.

But when I remove Bias supply resistor it's working fine. I have testes many drivers and decide to remove bias supply resistor from my circuit.

 

I have read that, this resister supply the IC during dimming or low voltage condition. I have tested that this driver is working fine without this resistor even at 175VAC.

 

So is it okay to remove bias supply resister from PCB (R4 on attached circuit.) ? 

 

I has also removed SMAJ350A long time ago to extend driver life. Actually this TVS diode shorted in just small spike of voltage and blow up some components like Inductors, Bridge Rectifier & than Fuse.

I have tested my driver in both condition with TVS diode & without TVS Diode.

And than I decide to remove TVS Diode SMAJ350A. After that it's working fine.

Is there any other way for surge protaction ? or I should use SMAJ400A instead of SMAJ350A 

 

attached circuit diagram.

Let me know if PCB layout required. 

첨부 파일Size
12Watt ND - Musin.png106.86 KB

Hi,

Yes you can remove R4 if it does not help to improve efficiency.

Yes, increase the rating of VR1 toSMAJ400A since you are using Buck topology.  This will do to protect the device from surge.

 

Regards,

PI-Jono 

Thanks for your quick reply.

 

One more question.

Some of my driver takes 1-2 seconds to start up during production. Is there any way I can remove start up delay ? 

Hi,

Normally the unit will start-up less than 300ms.  The only thing I can imagine is that it might be the design is marginal. I guess that it hits the SOA protection.  Kindly measure the drain current for the unit that having this problem.  Check if the inductor is saturating during start-up.  If yes, then adjust accordingly.

 

If this does not help, kindly share some of your start-up drain current waveforms for us to analyze.

 

Regards,

PI-Jono