TNY286 smps power supply - auto-restart issue

2 posts / 0 new

Hi colleagues,

I have designed an SMPS power supply based on the TNY286 integrated circuit and the issue that I am facing is auto-restart.

The circuit is powered with the 310VDC since I have rectified the 220VAC, and the SMPS transformer is from this link: https://store.comet.bg/download-file.php?id=2427
I have two outputs from the SMPS transformer and my plan was to generate two 15VDC rails using TL431 on one of the output winding.
One of the 15V rails has two buck regulators, for the 3.3V and 5V which has some sensors on them, one microcontroller so that rails is loaded but far from heavily.
The other 15V rail output has no load at this moment but is intended for the motor which will draw not more than 100mA.

When I want to achieve 15V on my outputs, restart occurs like it is described in the datasheet of the TNY286.
But when I change the feedback resistors (R30 and R31) in a way to get the 10V on the output, everything is fine. I have a stable voltage (no auto-restart) of 10V, 5V, and 3.3V. But unfortunately 10V is not enough for the motor, so I still need 15V.

The thing that confuses me is that on the page of the transformer it is stated that this transformer can produce 2x18V. Do you have some suggestion for me since I am getting out of ideas? Thank you all in advance!

Regards
Marko

AttachmentSize
schematic56.46 KB

I have solved the problem I had. The auto-restart stopped happening when I changed the capacitor C27 to 10uF and diodes D3 and D4 to SB3100.
First, the 10uF capacitor allowed the TNY268 to sink more current through the MOSFET.
Second, diodes need to be with high repetitive reverse voltage.

Regards
Marko

Topic locked